Home Forums Vote Status Store

Cant Play at the pokemon server at 1.15.2 version

Im at 1.15.2 version of minecraft and i cant download the forge or mod can some give me the link

You need minecraft forge 1.12.2 and pixelmon 7.2.2.
Download forge 1.12.2 from here - > http://files.minecraftforge.net/maven/net/minecraftforge/forge/index_1.12.2.html
Download pixelmon 7.2.2 from here -> https://reforged.gg/
Server ip is pikacore.sedexcraft.com